Jump to content

GTA V on PS4/Xb1 in

Website Problems/Issues/Requests


826 replies to this topic

#1 Psy

    You'll Never Walk Alone

  • Admin
  • 1,174 posts
247

Posted 11 March 2011 - 09:44 AM

If you've noticed something that's not working, or something that could be done better on the front end website, please let me know in this topic and I'll fix whatever issues we have. Bear in mind that the site is not built to be as interactive as iGrandTheftAuto.com, it's actually been based on GTA-SanAndreas.com where the content is more important than user input. All you can do is comment on pages, guides and news articles (as well as liking things on facebook and twitter). But if you have any issues, let me know.

#2 Qdeathstar

    Lovelord of the wastes

  • Gold Member
  • 4,636 posts
1,250

Posted 12 March 2011 - 03:38 AM

I've noticed on the main site a few issues.

The first one is that when someone makes a posts something and someone makes a comment, under comments it will say 2 even though there was one original post and one comment.

The Second is that if I try to enter my Display name as the name for the comment, it says that the Nickname has been reserved (I'm assuming you have to loggin) ; but, i don't see anywhere to log in when it gives me the error message. A login to continue link would be good.

The Third is that i don't see a link to the forums anywhere.

#3 TreeFitty

    Los Santos Fire Dept.

  • Admin
  • 4,991 posts
1,791

Posted 12 March 2011 - 03:57 AM

  • hmmm...
    boing says 2 comments but there's 1 (I posted a comment, said 3, deleted it, went back to 2)
    testicles says 1 but there's 2

  • I'm sure Psy will message you the admin log in.

  • Forum link and others will come. keeping the forums "hidden" for now. :)


#4 Psy

    You'll Never Walk Alone

  • Admin
  • 1,174 posts
247

Posted 12 March 2011 - 09:14 AM

 Qdeathstar, on 12 March 2011 - 03:38 AM, said:

I've noticed on the main site a few issues.

The first one is that when someone makes a posts something and someone makes a comment, under comments it will say 2 even though there was one original post and one comment.

The Second is that if I try to enter my Display name as the name for the comment, it says that the Nickname has been reserved (I'm assuming you have to loggin) ; but, i don't see anywhere to log in when it gives me the error message. A login to continue link would be good.

The Third is that i don't see a link to the forums anywhere.


1. I can't replicate that issue on the website. If something has no comments and I make one, it says it has 1... I think the reason Boing says it has 2 is because I changed the way the comments were counted after some comments were posted. Usually I'd do a query to count the number of comments on an article, but to save an extra query on every page load, now I set a field in the article itself with the number of comments. Once you make a comment it adds 1 to the number of comments. Obviously for boing it wasn't set to 0 when the first comment was made or something. Won't be an issue on any new content.

2. Admin usernames are protected from being entered when making a comment, unless you're actually logged in as an admin at the time. There's no actual member login system for the front end site, everyone posts as a guest, but admins have their names reserved to prevent people pretending to be them.

3. Forum links will be coming once the site is ready to go live.

#5 Qdeathstar

    Lovelord of the wastes

  • Gold Member
  • 4,636 posts
1,250

Posted 12 March 2011 - 05:50 PM

Am i an admin? Because i tried to enter "Qdeathstar" and it wouldn't let me.

#6 Psy

    You'll Never Walk Alone

  • Admin
  • 1,174 posts
247

Posted 12 March 2011 - 06:11 PM

I'll have to PM you the login details

#7 Qdeathstar

    Lovelord of the wastes

  • Gold Member
  • 4,636 posts
1,250

Posted 12 March 2011 - 09:36 PM

Sounds good.

One thing, i'm not sure if this is temporary, but i think this is a little too much jargon. How bout just :Enter the Name you wish to use: or something.

We do not have a login system for the front end of iGTA5. All comments are made by guests.

#8 ViceMan

    Decidedly average.

  • Members
  • PipPipPipPipPipPipPipPipPipPipPipPipPip
  • 2,627 posts
945

Posted 17 March 2011 - 07:42 PM

Got this error while looking through my profile:

Quote

Fatal error: Uncaught exception 'Exception' with message 'No like class available for null - null' in /home/igta5co/public_html/forums/admin/sources/classes/like/composite.php:332 Stack trace: #0 /home/igta5co/public_html/forums/admin/applications/core/modules_public/ajax/like.php(47): classes_like::bootstrap('null', 'null') #1 /home/igta5co/public_html/forums/admin/sources/base/ipsController.php(406): public_core_ajax_like->doExecute(Object(ipsRegistry)) #2 /home/igta5co/public_html/forums/admin/sources/base/ipsController.php(112): ipsAjaxCommand->execute(Object(ipsRegistry)) #3 /home/igta5co/public_html/forums/admin/sources/base/ipsController.php(65): ipsController->handleRequest() #4 /home/igta5co/public_html/forums/index.php(26): ipsController::run() #5 {main} thrown in /home/igta5co/public_html/forums/admin/sources/classes/like/composite.php on line 332


It was when I clicked the "Psy, TreeFitty and Akuma and 1 other like this" link for the comment i'd made. The link is http://www.igta5.com...on=like&do=more but it will redirect back to my profile if entered.

#9 Psy

    You'll Never Walk Alone

  • Admin
  • 1,174 posts
247

Posted 18 March 2011 - 02:14 AM

Did it just happen once or does it happen every time you do that?

#10 ViceMan

    Decidedly average.

  • Members
  • PipPipPipPipPipPipPipPipPipPipPipPipPip
  • 2,627 posts
945

Posted 18 March 2011 - 06:24 PM

Every time, did you click it yourself?

#11 Psy

    You'll Never Walk Alone

  • Admin
  • 1,174 posts
247

Posted 18 March 2011 - 11:53 PM

Ah yeah. I managed to replicate it. I'll look into it.

#12 Qdeathstar

    Lovelord of the wastes

  • Gold Member
  • 4,636 posts
1,250

Posted 20 March 2011 - 03:57 AM

We need a mod (or maybe it's a setting) that automatically turns double posts into one post.

And a skin for the asylum that has some homosexual flare.

#13 Massacre

    Warlord of the Wastes

  • Moderators
  • 9,055 posts
6,182
  • LocationThe Apocrypha

Posted 20 March 2011 - 04:12 AM

And the emoticons from the old forums, please. Unless I forgot something, that and what QD said about the double-post thing is all I need.

#14 TreeFitty

    Los Santos Fire Dept.

  • Admin
  • 4,991 posts
1,791

Posted 20 March 2011 - 06:07 AM

Duff is/was working on the emoticons.

#15 Massacre

    Warlord of the Wastes

  • Moderators
  • 9,055 posts
6,182
  • LocationThe Apocrypha

Posted 20 March 2011 - 06:09 AM

I got nothin' else to bitch about, then. Unless you think I could talk Psy into buying a hooker for me.

#16 Sheep

    Awesome

  • Gold Member
  • 60 posts
23
  • LocationNewcastle, UK

Posted 20 March 2011 - 09:03 AM

Yeah emoticons are being worked on

Just enabled the double post merger too

#17 ViceMan

    Decidedly average.

  • Members
  • PipPipPipPipPipPipPipPipPipPipPipPipPip
  • 2,627 posts
945

Posted 20 March 2011 - 06:08 PM

Whoa, those old title buttons take me back. They're the old GTA-SA.com ones.

#18 DuffMan

    Red Member Emeritus

  • Gold Member
  • 1,092 posts
251

Posted 20 March 2011 - 07:00 PM

 ViceMan, on 20 March 2011 - 06:08 PM, said:

Whoa, those old title buttons take me back. They're the old GTA-SA.com ones.

^_^

Just seeing what they look like, and what people think. I love them.

#19 Holocaust

    Litterer

  • Members
  • PipPip
  • 57 posts
-14

Posted 20 March 2011 - 07:13 PM

Yeah, I'm preferring them over the iGTA buttons. It's proper old-skool.

#20 Qdeathstar

    Lovelord of the wastes

  • Gold Member
  • 4,636 posts
1,250

Posted 20 March 2011 - 09:04 PM

I don't really like them, they are too GTA-Sanadreas ish, with the font and all.





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users